Next up: EclipseCon EuropeSign in
Enter your EclipseCon 2013 username.
Enter the password that accompanies your username.

Eclipse 4.x: Tips on API best practices for a 3.x plugin running on both platforms

Session Type: 
Standard [35 minutes]
Speakers

Eclipse 4.x is based on the Eclipse4 technology and supports the 3.x workbench API through use of the compatibility layer. But some 3.x APIs are more architecturally compatible with Eclipse 4 than others. This talk will touch on 3.x API patterns that are similar to the Eclipse 4 APIs, with lessons learned from the consumption of 4.2 in Juno.

Schedule info

Time slot: 
27 March 10:30 - 11:05
Status: 
Accepted

Audience

Track: 
Eclipse 4
Experience level: 
Intermediate
Slides: 

That would be out of scope

That would be out of scope for this talk, as its focus is writing 3.x plugins with patterns that hold up well in the 4.x Workbench.

Maybe we can extend this talk

Maybe we can extend this talk to describe how to use the new programming model for IDE plug-in development?

Copyright © 2013 The Eclipse Foundation. All Rights Reserved.